iKxin

flarum的composer命令&用法
正文flarum官方推荐的安装方法是Composer install,安装 composer 的教程可以自行Goo...
扫描右侧二维码阅读全文
29
2018/07

flarum的composer命令&用法

正文

flarum官方推荐的安装方法是Composer install,安装 composer 的教程可以自行Google和百度,LNMP和LAMP都是自带的,所以省略不谈,如果在本地搭建或者国内服务器搭建,发现使用 composer 更新慢、失败甚至出错的话,可以使用国内源。

sudo composer config -g repo.packagist composer https://packagist.phpcomposer.com

键入命令后,直接 composer update 就是使用国内源了

COMPOSER 常用命令

以单个插件 flagrow/ads 为例

安装 composer require

composer require flagrow/ads

删除 composer remove

composer remove flagrow/ads

更新 composer update

composer update flagrow/ads

同时在 flarum 根目录下执行 composer update 代表着更新整个 flarum 包括插件

安装插件时指定版本

(以插件 flagrow/upload 为例)

composer require flagrow/upload:0.4.13

也可以使用这样来更新一个大版本

composer require flagrow/upload:0.4.*

如果需要安装最新开发版

composer require flagrow/upload:dev-master

如果你想安装官方 flarum 的 开发版(dev),这里推荐个方法:

在安装完 beta 版后,修改根目录下的 composer.json 文件

把里面 flarum/core 版本改为 "flarum/core": "0.1.x-dev"

然后把一堆 flarum/flarum-ext-**** 版本全替换成 dev-master

也就是批量替换 ^0.1.0dev-master

最后 composer update 就可以更新到 dev 版了

最后修改:2019 年 06 月 27 日 02 : 25 PM
如果觉得我的文章写得不错,请赏我一杯咖啡

发表评论