前言

最近看到兰空图床更新到了 2.0 版本,增加了很多新特性,其中有一项是支持了多种数据库驱动。

本着越简单越好的想法,反正目前我的图床也只是自用不会有很多数据,不如趁这次升级,把它给换成 SQLite。

看了下文档里的要求是SQLite 3.8.8+,而 CentOS7 默认的 SQLite 版本都比较好,所以要给它升级一下。

升级

查看 SQLite 版本

[root@localhost ~]# sqlite3 --version
3.7.17 2013-05-20 00:56:22 118a3b35693b134d56ebd780123b7fd6f1497668
[root@localhost ~]#

不出意外都是 3.7.17 这个好几年前的版本,打开 SQLite 的官网看一下最新的版本,然后开始编译安装

https://www.sqlite.org/download.html

编译安装

wget https://www.sqlite.org/2022/sqlite-autoconf-3380100.tar.gz
tar -zxvf sqlite-autoconf-3380100.tar.gz
cd sqlite-autoconf-3380100
./configure --prefix=/usr/local/sqlite
make && make install

更改旧的 SQLite3

mv /usr/bin/sqlite3 /usr/bin/sqlite3_old

设置新的 SQLite3

mv /usr/local/sqlite/bin/sqlite3 /usr/bin/sqlite3

查看 SQLite 版本

[root@localhost ~]# sqlite3 --version
3.38.1 2022-03-12 13:37:29 38c210fdd258658321c85ec9c01a072fda3ada94540e3239d29b34dc547a8cbc
[root@localhost ~]#

至此,SQLite 就升级好啦。

Last modification:March 23, 2022
如果觉得我的文章对你有用,请随意赞赏