Flarum在几周前发布了0.1.0-beta.11版本,详见Flarum 0.1.0-beta.11 Released,那么就来看看怎么全新安装这个版本吧,前一篇文章已经装好了Composer并切换到了国内源,接下来的步骤就很方便啦。

准备工作

我的测试环境如下

Apache 2.4
PHP 7.3
MySQL 5.6

官方文档的服务器要求

Apache(启用mod_rewrite)或Nginx
PHP 7.1+具有以下扩展名:curl,dom,gd,json,mbstring,openssl,pdo_mysql,tokenizer,zip
MySQL 5.6以上或MariaDB 10.0.5以上
SSH(命令行)访问以运行Composer

官方文档似乎没有说明一个很重要的扩展,就是fileinfo,这个是flarum必须要装的扩展,宝塔面板可以直接安装,很简单,如果运行内存小于1G或等于1G,可能会安装失败,那么这时候就需要添加swap内存来保证安装成功,具体怎么添加不展开讨论了,宝塔的Linux工具箱里面有。

新建站点,数据库编码建议选择utf8mb4,当然utf8也行

这里先说一下上一篇文章没提到的,使用Composer的过程中遇到了很多警示,就像下面这种

根据警示说的,应该是宝塔的php默认禁用了相关函数,我总结了一下,要删除的有以下函数

putenv
pcntl_signal
proc_open

开始安装

首先cd到网站根目录下,rm -rf *删除掉所有文件

额,我试了下rm -rf删不干净,还是在宝塔面板的文件管理删除吧,.htaccess.user.ini都要删除掉,保证该目录下无文件
然后就是直接使用Composer安装

composer create-project flarum/flarum . --stability=beta

过一会就能安装好了,先不着急进网站,接着安装一个简体中文的插件先

//繁体中文
composer require csineneo/lang-traditional-chinese
//简体中文
composer require csineneo/lang-simplified-chinese

然后把网站目录下所有目录文件权限改为755,并将网站运行目录指向/public

到这就可以访问网站啦

Last modification:December 17th, 2019 at 12:02 am
如果觉得我的文章对你有用,请随意赞赏